
Создание топологии в САПР Cadence Allegro 

Продолжение (см. уроки 1 и 2) 

Итак, мы в предыдущих уроках с вами скачали и установили демонстрационную версию САПР 
Cadence Allegro, создали электрическую схему и промоделировали ее работу в симуляторе PSpice. 
Теперь давайте реализуем ее в виде печатной платы. Добавим в схему на входе и на выходе разъемы 
HEADER 2, как указано на схеме (Рис.1). Их можно найти в библиотеке Connector.olb в папке 
C:\Cadence\OrCAD_17.2_LITE\tools\capture\library или подобной, в зависимости от того, какие версии 
САПР Allegro или OrCAD у вас установлены. 

 
Рис.1. Схема с добавленными разъемами на входе и на выходе 



Теперь нужно будет указать посадочные места для всех компонентов в схеме. Мы предполагаем, что 
будут использоваться посадочные места из библиотек, которые идут с Allegro по умолчанию. Если у вас 
уже есть свои собственные библиотеки посадочных мест, не забудьте указать путь к их расположению. 
Это делается в закладке топологического редактора Setup->User Preferences->Paths->Library->psmpath и 
padpath (см. Рис.2). 

 
Рис.2. Пути к библиотекам символов и площадок в Allegro 

 

По умолчанию они находятся в папке C:\Cadence\OrCAD_17.2_LITE\share\pcb\pcb_lib\symbols. 

Также надо помнить, что необходимо точное соответствие в нумерации контактов символа и 
посадочного места. 

Есть несколько вариантов выбора посадочного места среди инструментов Cadence. 
Рекомендованный вариант заключается в использовании OrCAD Capture CIS, который позволяет  
хранить информацию о свойствах (например, наименование посадочного места или производителя) 
в базах данных ODBC в Windows-совместимых форматах, например, в Microsoft Access или SQL. 
Если вы используете этот метод, то вам не понадобится добавлять свойства вручную, как будет 
показано в следующих шагах. Мы покажем два способа для назначения посадочного места. 



 

1. Выделите компонент J1, затем ПКМ->Edit Properties, чтобы запустить Property Editor, либо 
просто двойной щелчок ЛКМ на компоненте (Рис.3). 

 
Рис.3. Окно редактирования свойств символа на схеме 

 
2. Введите значение для свойства PCB Footprint для J1 в соответствующей ячейке. В нашем 

примере посадочное место называется Jumper2, достаточно указывать только название, без 
расширения файлов (расширение по умолчанию – DRA). 

3. Сохраните изменения, закрыв окно Property Editor. Для этого выполните щелчок ПКМ на 
закладке с названием окна, а затем нажмите Close (либо используйте комбинацию Ctrl+F4). 

 
Рис.4. Сохранение изменений в свойствах компонента 

 
Вы можете вводить таким образом какие угодно свойства компонентов: Manufacturer, Part Number,  
Tolerance и т.п. Эти свойства потом могут быть использованы для создания перечней элементов или 
списка цепей. Следующий вариант позволяет задавать свойство сразу нескольким компонентам. 



4. Выделяем Headphone.dsn в “дереве” проекта, затем Edit>Browse>Parts 

 
Рис.5. Вход в режим просмотра символов в виде таблицы 

 
5. В следующем окне соглашаемся с предложенным вариантов (для получения дополнительной 

информации по Instances и Occurrences свойствам, можно обратиться к OrCAD Capture User Guide). 

 
Рис.6. Выбор режима просмотра свойств Instances (Образец) 

 
6. Мы увидим список всех компонентов в нашем проекте. Нам нужны только те, которые будут 

размещаться на самой плате. Поэтому мы можем игнорировать pspice-символы и выделить 
компоненты, начиная с C1 (щелчок ЛКМ) по R17 (Shift + ЛКМ). 

7. Затем Edit->Properties (или Ctrl+E) для открытия окна редактирования свойств. В нем вы увидите 
таблицу доступную для изменений, где мы можем внести необходимые нам свойства. 

 
Рис.7. Таблица свойств всех компонентов на  схеме 

  



 
8. Найдем столбец PCB Footprint и добавим в него следующие значения (Табл.1). Можно выделять 

несколько ячеек и вставлять значение групповым способом через Ctrl+V. 
 

RefDes C1…C6 C7 J1…J3 Q1…Q4 Q5…Q6 R1 R2…R13, 
R15, R16 

R14 

PCB 
Footprint smc0805 smc1210 jumper2 to236ab to252aa resadj smr0805 smr1206 

Таблица 1. Значения, которые надо внести в свойства PCB Footprint 

 

Затем щелчок ЛКМ->OK, закрываем окно Parts окончательно, выделяем Headphones.dsn и нажимаем  
File->Save, сохраняя все изменения. 

 

Проверка схемы на ошибки (Design Rule Checks) 
После того, как мы завершили работу со схемой, рекомендуется выполнить проверку на ошибки 
(DRC) для того что бы на этом этапе отследить возникшие при работе ошибки. Чтобы запустить DRC, 
надо выполнить следующие шаги: 

• В дереве проекта выделяем Headphone.dsn 
• Tools->Design Rules Check 
• В окне настроек можно оставить всё без изменений (Рис.8) 
• Нажимаем OK, запуская проверку 

 
Рис.8. Настройка функции проверки ошибок на схеме 



После непродолжительной проверки получаем файл Headphone.drc в папке Outputs в “дереве” 
проекта. Если ошибок нет, он будет иметь следующий вид (Рис.9). 

 
Рис.9. Результат проверки на ошибки в схеме 



Создание списка цепей (Netlist) 
1. В дереве проекта выделяем Headpone.dsn 
2. Выбираем Tools->Create Netlist, открывается окно настроек вывода списка цепей и создания 

проекта печатной платы. 

 
Рис.10. Окно настройки вывода списка цепей 

 

У нас по умолчанию отмечен пункт Create PCB Editor Netlist. Этот пункт отвечает за создание списка 
цепей, ниже можно указать папку, в которую он будет создаваться. Список цепей будет состоять из трех 
файлов: 

PSTCHIP.DAT – содержит информацию о разновидностях компонентов, которые используются в 
схеме. 

PSTXNET.DAT –файл соединений, называемый так же плоский (flat) или расширенный список цепей 
(expanded netlist), содержит в себе информацию о каждой цепи и каждом выводе, который к ней 
присоединен. 

PSTXPRT.DAT – может упоминаться как расширенный список компонентов (expanded parts list), 
содержит информацию о каждом компоненте с указанием его позиционного обозначения и секции. 

Полезно убедиться, что путь к конфигурационному файлу allegro.cfg указан корректно. Для этого 
надо нажать на кнопку Setup… и сравнить путь к файлу с видом <install_dir>\tools\capture\allegro.cfg, 
где <install_dir> - папка установки вашей программы. 

3. Если вы захотите увидеть содержимое всех трех файлов после генерации, отметьте пункт View 
Output, либо просмотрите их с помощью текстовых редакторов, выполняя открытие через проводник. 

4. Отметим пункт Create or Update PCB Editor Board (Netrev) для того, чтобы создать плату, в 
которую тут же будет подгружен список цепей. Затем в первой строке можно выбрать макет платы, 
который будет использоваться (либо это может быть плата, разведенная ранее, у которой изменилась 
схема), а во второй строке - месторасположение  нового файла. Мы оставим первую строку пустой. 



5. Затем выберем пункт Open Board in OrCAD PCB Editor, чтобы тут же открыть новую плату в 
редакторе топологии. И запустим генерацию нетлиста нажатием OK. 

 

Отступление: Могут возникнуть ошибки при создании списка цепей, их описание можно 
просмотреть в файле netlist.log, который будет находиться в папке назначения. 
Например, можно столкнуться со следующей проблемой: Pin number "0" found on Pin "B" of Package 
BC212AP/ZTX_3 , Q1: SCHEMATIC1, PAGE1 (3.15, 3.35). Pin number should be greater than "0". 

Это значит, что в наших символах транзисторов используются выводы с номером 0, а нумерация 
обязана начинаться минимум с единицы. Чтобы исправить это, поочередно выполним 
редактирование символов, которым необходима коррекция. Щелчок ПКМ на символе в схеме,  
затем Edit Part.  
В открывшемся символе двойным щелчком ЛКМ на каждом выводе заходим в их свойства и меняем 
номера на единицу больше. 

 
Рис.11. Изменение номера вывода транзистора 

 

Сохраним изменения, закрыв окно символа и выбрав пункт Update All, что распространит 
изменения на все одинаковые символы в схеме. 

 
Рис.12. Сохранение изменений для всех копий данного символа 

 

Исправив ошибки, проведите генерацию списка цепей вновь. 

 



В итоге в Allegro PCB Editor будет открыт файл топологии печатной платы Headphone.brd.  

 
Рис.13. Редактор топологии печатных плат Allegro PCB Editor 

 

Он имеет схожий вид с любыми другими САПР, сверху вы видите меню и панели инструментов, 
которые можно скрывать, либо настраивать вывод на них тех или иных кнопок. Внизу - командная 
строка, а под ней строка состояния: указан текущий слой и положение курсора. Справа три закладки: 
настройка видимости слоев Visibility, меню фильтров выделения и поиска Find, и меню опций текущей 
команды Options. Подробную информацию можно найти в инструкции через меню Help-
>Documentation Menu. 

 

Настройки редактора топологии 
Следующие шаги помогут выполнить базовые настройки редактора 

1. Setup>Design Parameters, закладка Design 
2. Заменим единицы измерения на Millimeter, размер листа на A3 и Left X, Lower Y на -50. 
3. Перейдем в закладку Display и выполним настройки в соответствии с изображением ниже 
4. Сохраним, нажатием ОК 



 
Рис. 14. Настройка единиц измерения - Millimeter, размера платы и координат центра(X, Y = -50) 

 
Рис.15. Настройки вкладки Display для большего удобства работы 



Создание границы платы 
Граница платы (board или design outline) определяет физический край платы, эта информация может 

быть  потом использована в механических САПР посредством экспорта через форматы IDF/IDX. 
Выполним следующие шаги: 
1. Shape->Rectangular (Также можно использовать круги или полигоны произвольной формы) 
2. Используем настройки как на Рис.16, задав нужный слой для рисования – Class->Board Geometry,  

Subclass-> Design Outline 

 
Рис.16. Настройки в окне Options для рисования прямоугольного контура 

 
3. В командной строке введем x 0 0, после чего начнется рисование с начала координат,  

а затем x 50 30, чем мы закончим рисование прямоугольника размером 30 на 50 миллиметров 
4. Нажмем ПКМ->Done или F6, чтобы выйти из текущей операции 
5. Если вам понадобится удалить границу платы, выделим её нажатием ЛКМ, а затем ПКМ->Delete, 

или вызовем команду Edit->Delete и затем отметим границу (вы можете выбирать объект и затем 
выполнять над ним операцию, либо выбирать команду и затем объекты, которые должны быть 
обработаны этой командой) 

6. Выберем Display->Zoom->Fit или нажмем F9, чтобы отобразить нашу плату целиком на экране 

 
Рис.17. Отображение контура платы на экране после команды Zoom Fit 



Если нужно, можно назначить другие цвета слоев, так называемых классов и подклассов: 
7. Setup->Colors или Ctrl+F5, или соотв. кнопка на панели инструментов 
8. Выбрать класс, например, Geometry и найти подкласс, например, Design Outline. Снизу в палитре 

отметьте необходимый цвет, а затем присвойте его нажатием на цветное окно около нужного объекта, 
затем нажмите ОК, чтобы закрыть окно. 



Добавление монтажных отверстий 
Теперь, когда есть контур печатной платы, можно добавить крепежные отверстия для её крепления. 
1. Откроем список имеющихся отверстий - Place->Mechanical Symbols 
2. Нам понадобится разместить четыре одинаковых символа, для этого перейдем в закладку 

Advanced Settings и отметим Disable напротив опции AutoNext 
3. Вернемся обратно и выберем символ MTG125 

 
Рис.18. Размещение механических символов - крепежных отверстий 

 
4. Нажмем клавишу Hide внизу окна 
5. После этого окно закроется, а выбранное отверстие будет готово к установке. Можно 

располагать его, нажимая в нужных местах мышью, либо вводить координаты через командную строку. 
Попробуем второй вариант. 

6. По очереди введем следующие команды, подтверждая каждую из них нажатием Enter 
x 2.5 2.5 
x 2.5 27.5 
x 47.5 27.5 
x 47.5 2.5 
7. Щелчок ПКМ->Done, в итоге у нас в углах платы будут расставлены 4 отверстия 
8. File->Save 

 
Рис.19. Размещение отверстий на плате 

Либо можно выполнять копирование одного поставленного на плату отверстия через Edit->Copy и 
выбор отверстия, либо вначале выбрав отверстие, а затем нажав ПКМ->Copy. 



Размещение компонентов 
Теперь самое время размещать на плате компоненты. Это можно сделать вручную, либо 

пользоваться автоматическим размещением. Наша плата имеет небольшое кол-во компонентов, 
поэтому вполне можно обойтись ручным размещением. Для этого также есть несколько вариантов, мы 
воспользуемся размещением по позиционному обозначению (RefDes) 

1. Place->Components Manually… 
В открывшемся окне приведены все неразмещенные на плате компоненты 

 
Рис.20. Размещение компонентов на плате – выбор из списка 

 
2. Отметим компонент, который хотим разместить, флажком рядом с его именем. Либо отметим 

сразу все, выбрав в дереве папку Components by refdes 
3. Выбираем кнопку Hide внизу окна и переходим к размещению компонента, при необходимости 

можно выполнить щелчок ПКМ->Rotate чтобы повернуть компонент. Во время поворота можно менять 
его параметры в закладке Options в правой части экрана 

 
Рис.21. Изменение угла поворота компонентов на вкладке Options 

 
4. Понадобится одно нажатие ЛКМ для выбора угла поворота и одно для установки компонента в 

выбранное место. Также можно вводить координаты компонентов в командную строку, как мы это 
делали с крепежными отверстиями. Если бы у нас был импортирован файл с размещением 
компонентов в виде перекрестий в местах установки, то мы могли бы использовать при размещении 
опцию привязки к пересечению ПКМ->Snap Pick to->Intersection. Чтобы выполнить размещение на 
нижней стороне платы, выполняйте команду ПКМ->Mirror во время размещения 

5. Используя все описанные инструменты, поместим компоненты на плате. Пример размещения 
указан на Рис.22 



 
Рис.22. Пример размещения компонентов на плате 

 
6. Настройка сетки для размещения компонентов и проводников выполняется через Setup->Grids…, 

сетка для размещения - это сетка для Non-etch слоёв, которые не выполняются травлением 

 
Рис.23. Настройка сетки для размещения и сетки для трассировки 

 
В будущем, если вам понадобится найти какой-либо компонент на плате, воспользуйтесь панелью 

Find в правой части экрана. Там следует выбрать в разделе Find By Name интересующий вас тип 
объекта, например, компоненты - Symbol (or Pin), затем нажать more… и в открывшемся меню 
выделить искомые объекты, переносом их в правое окно, затем нажать Apply, и программа выполнит 
их подсветку и укажет расположение. Точно так же можно выполнить поиск цепей. Также помогает 
ориентироваться «горячая» связь между схемой и топологией: выделив компонент на схеме, можно 
увидеть его расположение в топологии. 

 



Проверка на ошибки (design rule checking) 
В редакторе печатных плат проверка на ошибки может выполняться онлайн или по запуску 

соответствующей команды. По умолчанию она выполняется онлайн, и когда в процессе работы 
нарушаются те или иные правила, тут же возникают маркеры об ошибках следующего вида: 

 
Рис.24. Индикация ошибок с помощью маркеров 

 
Включение/выключение такой проверки выполняется через Setup->More->Enable On-Line DRC. 
 

Задание правил проектирования (Constraints) 
Указать основные зазоры и физические ограничения для нашей платы можно, зайдя  

в Setup->Constraints. Откроется окно с подробными настройками, для нашего примера мы все из них 
оставим по умолчанию, пока лишь изменим используемую ширину линий. 
Для этого выполним: 

1. Выделим раздел физических (Physical) ограничений 
2. Перейдем в нем в закладку наборов правил Physical Constraint Set, All layers  
3. Поменяем значение min line width в строке Default c 0.127 на 0.5 

 
Рис.25. Задание правил и ограничений 

 



4. Теперь, если мы перейдем в закладку Net и развернем там список цепей, нажав на «+» в строке 
XNets/Nets, то увидим, что новое правило сработало для всех цепей, которые используют набор 
Default. 

 
Рис.26. Распространение набора правил (Physical CSet) DEFAULT на все цепи 

 
Редактор ограничений предоставляет множество возможностей для управления правилами, поэтому 

рекомендуем обратиться к обучающим видео на нашем YouTube-канале для его освоения. 



Трассировка 
После размещения компонентов и задания правил можно приступать к трассировке. В Allegro можно 

пользоваться как ручной трассировкой, так и автоматической. Обычно критические цепи разводятся 
первых вариантом, затем они фиксируются и трассируются автоматом все остальные, но всё зависит от 
предпочтения пользователя. 

 
Ручная трассировка 
Маршрут ручной трассировки имеет приблизительно следующий вид: 
• Задание границы платы, используемых переходных отверстий и сеток 
• Заливка полигонами земли и питания 
• Выполнение fanout – коротких соединений контактных площадок  

с переходными отверстиями. Проверка их подключения с полигонами питания 
• Трассировка остальных цепей, используя ручные инструменты 
• Оптимизация проложенных проводников 
• Проверка на ошибки 

Выберем Display->AssignColors и выберем цвет для цепи VPP в окне Options справа. Затем перейдем 
в закладку Find и переключим на поиск цепей (Net) в разделе Find By Name, нажмем More… и 
перенесем в правое окно цепь VPP. После нажатия Apply все площадки и связи, принадлежащие этой 
цепи, должны окраситься в выбранный цвет. Так же можно перекрасить, не прерывая выполнения 
команды, остальные цепи, которые мы захотим выделить.  

После этого выполним команду Route->Connect (можно вызвать нажатием F3 или на иконку ), 
укажем необходимые параметры проводников в панели Options справа и выполним трассировку 
отмеченных цепей. 

 
Рис.27. Окно задания опций для трассировки 

 

Нам не обойтись без переходных отверстий, их можно выбрать в редакторе ограничений (Constraint 
Manager - CM). Вернемся в нем в закладку Physical и найдем столбец Via, выполним нажатие ЛКМ в  
ячейке для набора Default, откроется окно выбора переходных отверстий (Рис.28). 



 
Рис.28. Выбор подходящего типа переходных отверстий для трассировки 

 

Слева будут отверстия, доступные из библиотек Allegro, справа – используемые в проекте как 
переходные отверстия. Найдем что-нибудь подходящее, задав фильтр буквами VIA, а затем перенеся 
двойным нажатием ЛКМ пад-стек в окно справа. Нажмем ОК и выйдем из CM. Теперь при трассировке, 
при двойном нажатии ЛКМ или при выполнении команды ПКМ->Add Via, будет происходить 
постановка переходного отверстия. Если у вас несколько доступных вариантов, то можно будет 
переключаться между ними в окне Options. После трассировки и перестановки некоторых 
компонентов, мы получили следующий результат (Рис.29). 

 
Рис.29. Результат предварительной трассировки. 



Добавление полигонов 
Мы проложили единичные проводники, теперь добавим полигоны питания и «земли». Для этих 

цепей лучше использовать полигоны, так как это, например, позволяет уменьшить плотность тока и 
даёт экранирующий эффект. 

Для создания контура полигона можно использовать в качестве основы геометрию края платы. Это 
особенно удобно, когда плата имеет сложную форму. Для этого активируем команду Shape->Copy 
Shape, обратим внимания на панель Options, там нужно указать в каком слое будет находиться новый 
полигон, отметим так же пункт Create dynamic shape и выберем Contract c расстоянием 0.5. Последнее 
означает, что новый полигон будет «ужат» на 0.5 мм со всех сторон от исходного. После этого 
выполним щелчок ЛКМ на границе платы. Должен появиться полигон следующего вида (Рис.31) 

    
Рис.30. Опции для копирования полигона в новый слой с уменьшением размеров 

 
Рис.31. Результат – создан полигон в слое BOTTOM 

 

Теперь осталось назначить полигону цепь. Перейдем в режим редактирования полигонов, нажатием 

на кнопку  в панели инструментов, либо нажав на название текущего режима в строке состояния в 
самом низу страницы и выбрав там Shape Edit. Выделим полигон нажатием ЛКМ, затем откроем меню 
нажатием на нем ПКМ, в котором найдем команду Assign Net. Активируем её, и в её настройках, нажав 
на многоточие, найдем и выберем цепь «земли» - «0». Нажатием ПКМ->Done завершим команду. 

Теперь в ручном режиме нарисуем полигон цепи VPP, для этого выполним Shape->Polygon и вновь 
обратимся к настройкам команды 



 
Рис.32. Настройки команды создания полигона 

 

После того, как вы настроите всё соответствующим образом, начнем рисовать полигон, он в итоге 
должен покрывать все переходные отверстия и контактные площадки цепи VPP. После его завершения, 
может получиться так, что он не будет заполнен медью, так как в том месте уже есть полигон «земли». 
Тогда, выделив полигон питания, выполним ПКМ->Raise Shape Priority. После этого его приоритет будет 
увеличен, и полигон будет заполнен в первую очередь. Для того что бы настроить параметры связи 
полигонов с площадками, нужно перейти в Shape->Global Dynamic Parameters… Там на закладке 
Thermal relief connections можно выбрать вид контакта для сквозных и планарных контактных 
площадок или переходных отверстий, указать минимальное и максимальное количество перемычек и 
их ширину. В итоге, нижний слой платы приобретет приблизительно следующий вид (Рис.33). 

 
Рис.33. Вид слоя Bottom после создания полигонов 



Видно, что полигон «земли» оказался разбит на две части, для их лучшей связи можно, уже 
рассмотренными инструментами, создать дублирующий полигон на верхнем слое и связать их 
дополнительными переходными отверстиями. Отверстия можно ставить, используя команду Connect, 
либо копирую имеющиеся, выбрав одно и нажав на нем ПКМ->Copy. 

 
Рис.36. Итоговая топология слоев Top и Bottom 



Проверка и отчеты по топологии 
Когда все цепи разведены, можно выполнять проверку и формировать отчеты. 

1. Check->Design Status… 
Вы увидите краткую информацию о вашем проекте, зеленые флаги покажут вам, что ошибок нет, а, 

найдя красные или желтые, можно нажать на них и увидеть в чём их причина. 

 
Рис.37. Окно отображения статуса проекта 

 
Кнопки Update to Smooth и Update DRC обновляют  полигоны и информацию об ошибках. 
 
2. Export>Quick Reports>Summary Drawing Report 
Как пример, этой командой мы создадим общий отчёт о графических объектах на плате. 
 
3. Export->Reports 
Отроется еще один список отчётов. Перенеся название Component Report в нижнее окно двойным 

нажатием, а затем, нажав Generate Reports, мы получим отчет о положении, названии и номиналах 
всех компонентов. 

 
Есть множество вариантов отчетов и возможность их настройки, об этом более подробно можно 

узнать из других учебных материалов. 



Постобработка  
Здесь мы приведем некоторые общие инструменты, которые могут понадобиться после завершения 

работы с топологией. 
 

Переименование компонентов вручную 
Используя меню Setup->Colors, погасим отображение всего, кроме следующих слоев: 

Geometry\Design_Outline, Geometry\Assembly_Top, RefDes\Assembly_Top и Pin\Top. Активируем 
команду Edit->Text и выберем позиционное обозначение, которое хотим изменить. Его значение 
появится в командной строке, и там же его можно будет переписать, а затем нажать Enter для 
подтверждения. Если вы попробуете изменить позиционное обозначение на уже существующее, то 
произойдет его замена также и у другого компонента. Например, имея на плате резистор R6, мы 
попробуем поменять название R5 на R6, тогда первоначальный R6 автоматически станет R5. 

 

Переименование компонентов автоматически 
Обычно принято пронумеровывать компоненты исходя из их положения на схеме, но если в этом 

отношении вас ничего не ограничивает, можно пронумеровать их в зависимости от положения на 
плате. Для этого выполним команду Manufacture->Auto Rename Refdes->Rename.  

 
Рис.38. Авто-переименование компонентов 

 



Выберем Use default grid, а затем перейдем по кнопке More… 

 
Рис.39. Окно настройки автоматического переименования компонентов на плате 



В открывшемся окне настроек можно выбрать, на каких слоях, и в каком порядке проводить 
перенумерацию. Можно добавить префикс, отдельный для компонентов на верхнем или нижнем слое, 
либо оставить без них, как мы и сделаем. Так же отметим пункт Preserve Current Prefixes, сохранив 
текущие буквенные обозначения. Нажмем Close, сохранив изменения, и запустим процедуру нажатием 
Rename в предыдущем окне. Редактор плат выполнит её, статус можно будет увидеть в командной 
строке, а результат на плате. 

 

Обратная аннотация 
При работе с печатной платой могут быть выполнены различные изменения, которые необходимо 

учесть в электрической схеме. Это может быть, например, перенумерация компонентов или 
свапирование выводов. Что бы синхронизировать после этого схему с платой, нужно выполнить 
обратную аннотацию. Для этого в OrCAD Capture выделим в «дереве» проекта его название 
headphone.dsn, затем перейдем в Tools->Back annotate, откроется окно с настройками 

 
Рис.40. Окно обратной аннотации в OrCAD Capture 

 
Выберем закладку PCB Editor и отметим пункт Generate Feedback Files, если это еще не сделано. 
Не забудьте убедиться, что указан верный файл конфигурации allegro.cfg, он должен находиться по 

адресу <папка установки программы> \tools\capture\allegro.cfg. Также укажите правильный путь для 
расположения новых файлов списков цепей. 

Помимо всего будет создан swp-файл, в котором будут перечислены изменения, сделанные в 
топологии и необходимые к аннотации в схему. Для него также нужно указать расположение. Больше 
информации о нем можно прочитать в OrCAD Capture User Guide. В нашем примере он будет 
называться headphone.swp и находиться в папке headphone\allegro.  

Выделим, если еще этого не сделано, пункт Update Schematic для того, чтобы в наш проект был 
выполнен перенос информации из swp-файла с помощью обратной аннотации. Если мы хотим увидеть 
содержимое swp-файла после его генерации, отметим пункт View Output. После нажатия на OK, 
программа спросит нас о сохранении проекта перед проведением аннотации - соглашаемся.  
OrCAD Capture создаст новые файлы списков цепей (PSTCHIP.DAT, PSTXPRT.DAT, PSTXNET.DAT) 
и swp-файл. Он будет открыт в отдельном окне, а в схему будут внесены перечисленные изменения. 



Прямая аннотация 
С тем же успехом можно вносить изменения, сделанные в схеме, в готовую или частично 

выполненную топологию. Для этого в «дереве» проекта выделим основной файл headphone.dsn  
и перейдем в Tools->Create Netlist, откроется окно следующего вида 

 
Рис.41. Окно генерации нетлиста для внесения изменений в плату 

 
Отмечаем пункт Create or Update PCB Editor Board (Netrev), в его опциях в первой строке - Input 

Board File, указываем входной файл текущей топологии, а во второй - Output Board File, указываем 
выходной, это может быть тот же самый файл. Нажимаем OK, будет созданы новые файлы списков 
цепей и открыта топология с внесенными изменениями. После множественных изменений бывает 
такое, что, когда мы указываем один и тот же файл как входной и выходной, изменения не загружаются 
в плату, в таком случае стоит использовать более длинный путь. Для начала сгенерировать только 
файлы списков цепей, а затем загрузить их в PCB Designer, через команду File->Import->Logic в нём. 



 
Рис. 42. Окно загрузки списка цепей в редакторе Allegro PCB Editor 



«Горячая» связь между схемой и платой 
OrCAD Capture и Allegro PCB Designer тесно связаны между собой, что позволяет в реальном времени 

следить за взаимным расположением и группировкой компонентов. Выделяя компоненты в одной 
программе, вы тут же видите их во второй. Обычно это связь работает по умолчанию, а если нет, то 
необходимо сделать следующее: 

1. В редакторе OrCAD Capture выделим файл проекта headphone.dsn  
2. Перейдем в Options->Preferences 
3. Выберем закладку Miscellaneous 
4. Найдем и отметим пункт Enable Intertool Communication 
5. Щелчок ЛКМ на OK 
6. Убедитесь, что в топологию загружена последняя версия списка цепей 
После этого, например, выделив конденсатор на схеме, мы увидим его подсветку и в топологии. 

      
Рис. 43. Динамическая связь между схемой и топологией 

 
Аналогично и в топологии, выполнив щелчок ПКМ->Highlight на нужном компоненте, и выбрав 

любой вид подсветки, вы получите его выделение на схеме. Если же нам нужно погасить все 
выделенные компоненты,  выберем Display->Dehighlight и в настройках команды справа в окне 
нажмем кнопку All. 

 
Рис.44. Сброс подсветки всех выделенных компонентов в PCB Editor 



 
 

Создание выходных файлов 
Последние задачей при разработке печатной платы является создание файлов для передачи заводу 

изготовителю печатных плат, отделу комплектации и монтажному участку. Для этого могут 
понадобиться Gerber-файлы c информацией о рисунке слоев, файлы сверловки формата Excellon NC, 
DXF-файлы для создания чертежей, файлы формата IPC2581, ODB++ или файлы для печати на принтере. 
Всё это можно найти в закладке меню Export. 

Перед созданием выходных файлов стоит лишний раз убедиться, что в плате нет ошибок. 
Генерация герберов: 
1. Выполним Export->Gerber Parameters 

 
Рис.45. Окно параметров для вывода файлов Gerber для производства 

 
2. Выберем формат Gerber RS274X, наиболее часто используемый сейчас при производстве 
3. Выберем по пять знаков до и после запятой в координатах объектов, Integer places и Decimal 

places 
4. Можно указать дополнительный текст, который будет добавляться к названию файлов Gerber в 

начале и конце, Prefix и Suffix. Например, название проекта. 



5. Пункты Leading и Trailing zeroes отбрасывают при генерации незначащие нули до и после 
запятой, нужно стараться сохранять один вид этих настроек для всех выходных файлов, чтобы не 
возникало сбоев. 

6. Убедимся, что единицы измерения – миллиметры, и сохраним изменения – OK 
7. Перейдем в Setup->Colors, погасим все слои, нажав Off в Global Visibility 
8. В закладке Stack-up отобразим слой Soldermask_Top для Pin 
9. В закладке Geometry отобразим все слои Soldermask_Top 
10. Перейдем в Export->Gerber, в окне со списком файлов нажмем правой кнопкой на одном из них и 

выберем Add, добавив новый, назовем его SM_TOP. Тем самым мы создали гербер с 
информацией о защитной плёнке на верхней стороне. Если мы раскроем список слоёв, которые 
пойдут в этот файл, то увидим только те, которые отображены сейчас на экране. 

11. Повторим эти шаги для того, чтобы создать гербер SP_TOP с информацией  о паяльной пасте на 
верхней стороне.  
Для этого используем слои Pastemask_Top/Pin, Package Geometry/Pastemask_Top 

12. Также не забудем слой BRD с границей платы, Board Geometry/Design_Outline. 
Для него справа укажем параметр Undefined line width равный 0.1 мм, потому что граница 
задана полигоном с нулевой шириной линии, и иначе она будет проигнорирована при выводе 

13. В итоге выберем все гербер-файлы, нажав Select All, и создадим их нажатием на Create Artwork 

 
Рис.46. Окно вывода файлов Gerber с подготовленными группами слоев 

 
При возможности, можно посмотреть созданные гербера в программе CAM350 или аналогичной. 

Они будут иметь следующий вид (Рис.47). Также вы можете посмотреть созданные файлы в самом 
редакторе Allegro PCB Editor, втянув их командой File->Import->Artwork в специально созданные для 
этого новые слои в классе Manufacturing (см. описание ниже). 



 
Рис.47. Просмотр выведенных файлов Gerber в сторонних программах 

 

Вывод информации об отверстиях 
Для начала, создадим в файле топологии перечень используемых отверстий  (Drill Legend). 

Отобразим на экране всё информацию, имеющуюся в проекте (Закладка Visibily->Global Visibility->ON). 
Меню Manufacture->Create Drill Table, ничего не меняя, нажмем OK и поместим таблицу на экране 
щелчком ЛКМ (Рис.48) 

 

 
Рис.48. Таблица с типами отверстий 

 
Теперь создадим файл сверловки. Перейдем в меню Export->NC Drill. В открывшемся окне и в 
окне по нажатию кнопки NC Parameters настроим всё следующим образом, соответствующим 
настройкам для вывода гербер-файлов. 



    
Рис.49. Настройка вывода файлов сверловки 

 
В итоге, после закрытия окна NC Parameters и нажатия кнопки Drill мы получим файл с координатами 

и параметрами отверстий. 
Для проверки, мы его добавили к ранее созданным герберам в сторонней программе 

 
Рис.50. Просмотр файлов Gerber и Drill в сторонней программе 

 
Всё совпало, вывод закончен успешно. 
Также просмотр можно выполнить средствами Cadence, для этого создадим новый файл платы  

File->New, тип Board, название, например Artwork. Перейдем в меню Setup->More->Subclasses.  
В нем зайдем в класс Manufacturing и добавим новый подкласс Artwork 



 
Рис.51. Добавление нового подкласса (слоя) 

 
Согласимся со всем, нажав OK, а затем выполним импорт гербер-файла, Import->More->Artwork. 

Укажем класс Manufacturing и подкласс Artwork, нажав «…», найдем любой из созданных  
гербер-файлов, выберем его и нажмем кнопку Load file. У нас появится контур будущего объекта, 
поставим его на любое место. Эту последовательность можно выполнить для всех файлов, которые вы 
хотите просмотреть. 

На этом знакомство с маршрутом проектирования Cadence Allegro и OrCAD можно считать 
законченным. Мы создали схему, промоделировали ее, создали печатную плату и вывели файлы для 
производства. Более подробную информацию по функциям САПР можно получить на сайте 
www.pcbsoft.ru. 

http://www.pcbsoft.ru/

